SSL and HDD – Two completely different Problems that used up way too much time today…

Originally I wanted to write a howto (naturally i write them mainly for my future self) but as its very late i am too lazy for writing it right now…

But… the already mentioned friend of mine and i are using the same server and because we have different websites on it at the same time we use vhosts on the apache webserver.

I had already configured ssl for the existing domains and he bought a new domain… i think you can already guess where this is going.

he wanted to have working ssl on his new domain. well… i spent about 8 hours today fixing the setup because it went to not working at all… at least now i know every possibility how to not configure vhosts with ssl… AND at least one that works and is relatively clean and not awful.

Other things that happened: My HDD is breaking down. Naturally i have a backup, but as it is the hdd with the not much used data, my backup is on tape so i decided, as the hdd isnt broken down yet (it spins down every now and then und has read-errors) i just copy the data from there. if its not working i still have the backup, and as i do the backups monthly (mid of month) i can be sure to get all the data if it works. As its always automatically unmounting its a very timeconsuming process to find the right arguments to copy the data, but it seems to be working right now…

As i was fixing my computerissues anyway i did a system-upgrade of my desktop-pc as well – for good measure… 😀

Now im going to sleep – my pc is working and that usually lets me sleep very well as i know at least some”body” is doing work then…

Leave a Reply

Your email address will not be published.